Which Nokia devices are supported?

In order to run WhatsApp, you must be using a supported phone.

For supported Nokia devices please use the box below:

If you are using a Nokia S40 phone, please read this article.

For more specific information, see supported device articles for: Android | iPhone | BlackBerry | Windows Phone | BlackBerry10.

Cheers,
WhatsApp Support Team