I can't install WhatsApp on my BlackBerry 10

WhatsApp Messenger is available for your BlackBerry 10 smartphone in BlackBerry World. In order to install and use WhatsApp Messenger on BlackBerry 10, you will need to have BlackBerry 10 Software Release 10.0.10.82 or later, otherwise known as BB OS Version 10.0.10.648, for your BlackBerry device.

You can check your BB OS version in the BlackBerry Settings:

BB Settings > About > Category : General > OS Version

If your BB OS version is less than 10.0.10.648, you will need to wait for a device update from your mobile provider. Generally, your mobile service provider is responsible for releasing device updates for your BlackBerry 10 phone.

Please note that only official BlackBerry 10 Software Releases are supported. Pre-release and developer versions may be incompatible with WhatsApp.

For more specific information, see supported device articles for: Android | iPhone | BlackBerry | Nokia S40 | Nokia S60 | Windows Phone.

Cheers,
WhatsApp Support Team