Why can't I send emoji/emoticons/smileys?

To send emoticons/emoji/smileys, you need BlackBerry OS Software 5.0 or higher.

BlackBerry OS 4.6 and 4.7 can be upgraded to 5.0. You should check with your service provider on how to upgrade your device or visit the BlackBerry website on your computer and download the updated OS for your phone, after selecting your carrier. Then, use the Desktop Manager to install the new OS.

Cheers,
WhatsApp Support Team